PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : [FTP-Server] BulletProof hinter Router.



gnu2
07.08.04, 21:46
Auch auf die Gefahr hin, dass sich jemand beschwert wegen dem Thema......

Ich habe heute meinen Router (Fritz Box Fon) installiert, vorher mein Image wieder drauf gespielt.

Router hat: 192.168.178.1
PC1: 192.168.178.2 (Gene6 FTP Server)
PC2: 192.168.178.3 (Windows)
PC3: 192.168.178.4 (Linux)

Meine Dyndns-Adresse ist: gnu2.dyndns.org:666 (bis gestern)

Bis jetzt war der PC direkt am Netz. Gene6 FTP Server lief auf Port 666. Zugriffe von aussen ohne
Probleme machbar durch http://www.baliciel.com/softwares/baliddns.htm. Ist halt auch ein Client, der mir meine DDNS verwaltet.
Dieses Tool startet im Autostart-Ordner und sucht anhand der Netzwerkkarte die IP. Diese habe ich ja jedem PC fest zugewiesen. Also in diesem Fall 192.168.0.2. Diese wird auch angezeigt.
In der Kommandozeile kann ich mich anpingen (gnu2.dyn...), aber ohne den Port 666. Wenn ich diesen auch noch angebe, findet der Ping nichts mehr.
Also kann es theoretisch nur an den Einstellungen des G6Servers liegen. Ich komme aber nicht drauf.
Was mich irritiert ist, das doch der Router (192.168.178.1) die Anfrage an PC1 (192.168.178.2) weiterleiten muss. Da gibt es aber keine Einstellungen im Router. Der Port 666 (TCP) ist freigegeben.

Wer kann mir helfen, ehe ich den PC zum Fenster heraus werfe. Es kann normalerweise nicht viel sein, aber ich komme nicht dahinter.

Frank


Meine HOST Datei habe ich auch bearbeitet, dass sollte aber nicht stören, da es ja den Betrieb des FTP nicht stört

127.0.0.1 localhost
192.168.178.1 fritz.box
192.168.178.2 dummi
192.168.178.3 jutta
192.168.178.4 linuxserver

Achso, ich habe einen Zugang erstellt. Kann es mal einer testen?

ftp://test:test@gnu2.dyndns.org ///entweder mit :666, oder ohne dem Port

KOENICH
07.08.04, 22:20
Welchen DynDNS Klienten benutzt du denn?
Als deine IP kommt nämlich 192.168.178.1 - eben deine lokale ;)


----
edit
Du hast ja geschrieben, welchen du verwendest... Nutze erstmal einen, der deine IP anhand von externen Quellen herausfindet - deine lokale bringt schließlich nix von extern (ich selber verwende DirectUpdate)

gnu2
07.08.04, 23:08
Danke Dir.

Habe DirectUpdate installiert.
Unter "Engine Connection" muss da der localhost mit dem default Port stehen, oder muss ich da die IP
und den Port des G6 Servers angeben?
Naja, mit diesem Teil kenne ich mich nicht so aus :( .

Mr.Smokey
04.09.04, 03:03
Moin Volks...


mal eine kleine Hilfe für euch...

Direct Update muss bei Engine Connection nix eingestellt werden,
ausser du gehst über einen Onlinetarif rein, der dich jede min. was kostet, oder nen Volumentarif ist.. Dass ist sozusagen eine DFÜ Einwahl...

Daher auch die "KeepAlive" Funktion, welche die "DFÜ" Verbindung nach Trennung gleich wieder Verbinden soll...
Also Achtung wenn ihr solche Tarife habt... KOSTEN

Nun zum DynDns und Server/Router Problem...

Du must deinen DynamicDNS Account "deinname.dyndns.org" oder ähnlich auf "enable Wildcards" stellen

Dann dein FTP Proggy auf port 21 oder beliebig,
bei beliebigem Port´, muss der im Router wenn die Firewall [Inbound/Outbound] an ist, freigegeben werden.

Port 21 ist ja immer Frei beim Router... normalerweise.

Nuja die Anfragen an DeinName.DynDns.Org gehen durch Hilfe des DynamicUpdate Tools direkt an den Router... (Account einstellen bei Status -> Create [oben])

Der Router sollte mit eingestellter Firewall den Port direkt auf eine IP Adresse [Class C] leiten... (seht ihr wenn ihr den Freigebt)
Also auf in deinem Fall 192.168.178.2...

Dann sollte das Connecten funktionieren mit Dynamischer IP Adresse. Ich gebe in meinem Router den Port 21 immer zur Sicherheit nochmal auf meine Class C Adresse ein...

Wenn dein FTP Proggy also läuft. und zwar richtig in der config, dann sollte alles funzen....

Hoffe ich konnte helfen...

Mfg
Mr.Smokey
Mr.Smokey@my-mail.ch