PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Tooltipp: Tastatur-Sondertasten nutzen mit LinEAK



Supernature
11.02.03, 17:54
Du besitzt eine Multimedia- oder Internet-Tastatur mit schicken Zusatztasten, die unter Linux so langsam, aber sicher einstauben? Das muss nicht sein!
Mit dem kleinen Tool "LinEAK" (Linux support for Easy Access and Internet Keyboards) lassen sich bei den meisten Spezial-Tastaturen die Zusatztasten wieder zum Leben erwecken.
Und damit Du nicht auf Dich alleine gestellt bist, helfe ich auch ein bisschen bei der Installation und Einrichtung :)

Zum Zeitpunkt, da dieser Text geschrieben wird, ist Version 0.4pre3 aktuell - ich werde versuchen, bei künftigen Aktualisierungen am Ball zu bleiben.


Zuerst lädtst Du Dir die aktuelle Version von http://lineak.sourceforge.net herunter. Dort findest Du neben dem Download auch die aktuellen FAQ sowie eine Liste der aktuell unterstützen Keyboards. Aber selbst wenn Dein Keyboard nicht in der Liste steht, findest Du im Kapitel "Documentation" auf der Seite eine Anleitung, wie es vielleicht trotzdem funktioniert.

Aber nun mal ran an den Speck, wir stürzen uns auf die Installation:
Öffne eine Konsole, wechsle in das Verzeichnis, in das Du die heruntergeladene tar.gz-Datei gespeichert hast, und gib Folgendes ein (bei Folgeversionen sind die Befehle durch logisches Kombinieren entsprechend anzupassen ;)):

gunzip lineakd-0.4pre3.tar.gz
tar xf lineakd-0.4pre3.tar

Damit hast Du die Datei in das neu erstellte Verzeichnis lineakd-0.4pre3 entpackt.
Für die nun folgenden Schritte wechselst Du in den root-Modus.
Mit "cd lineakd-0.4pre3" springst Du in das neue Verzeichnis, dann folgt der berühmte Installations-Dreisatz:

./configure
make
make install

(möglicherweise kommen bei configure Fehlermeldungen, weil das eine oder andere Entwicklerpaket fehlt. Normalerweise sind die Meldungen eindeutig, solltest Du dennoch Probleme haben, frag einfach nach).

Das war es eigentlich schon, LinEAK ist nun installiert und einsatzbereit, aber noch nicht konfiguriert. Melde Dich nun wieder als root ab und arbeite als normaler Benutzer weiter. Als Nächstes gilt es herauszufinden, unter welchem Code LinEAK Deine Tastatur erkennt. Dies findest Du durch das Kommando

lineakd -l

(das ist ein kleines L ;)) heraus. Nun werden alle unterstützen Keyboards fein säuberlich aufgelistet. Der Logitech Cordless Desktop Optical hat zum Beispiel den Code LTCDO. Diesen teilen wir nun LinEAK mit, damit es eine entsprechende Konfigurationsdatei erstellt. Das sieht in unserem Beispiel so aus:

lineakd -c LTCDO

Dadurch wird in Deinem Home-Verzeichnis ein Unterverzeichnis .lineak erzeugt und in diesem die Datei lineakd.conf abgelegt.
In dieser Datei werden die Kommandos gespeichert, die den Spezialtasten zugeordnet sind. Logischerweise ist sie erstmal leer. So könnte sie zum Beispiel aussehen:






# LinEAK - Linux support for Easy Access and Internet Keyboards
# Copyright (c) 2001,2002 Mark Smulders <Mark@PIRnet.nl>
# http://lineak.sourceforge.net
#
# lineakd configuration file
#
# example key configuration:
# play = "xmms --play-pause"
# eject = EAK_EJECT
#
# available special actions:
# EAK_EJECT
# EAK_VOLUP
# EAK_VOLDOWN
# EAK_MUTE
# EAK_SLEEP
#

# LinEAK Configuration file for Logitech Cordless Desktop Optical

# Global settings
KeyboardType = LTCDO
CdromDevice = /dev/cdrom
MixerDevice = /dev/mixer

# Specific keys of your keyboard
go =
webback =
wheelbutton =
sleep =
finance =
mysites =
social =
favorites =
previous =
next =
media =
volumedown =
volumeup =
mute =
play =
stop =
iTouch =
mail =
shop =
search =
home =

# end lineakd.conf



Es gibt auf der Homepage von LinEAK auch zwei grafische Tools zur Konfiguration, angesichts der einfachen Struktur der Konfigurationsdatei habe ich aber darauf verzichtet, mir eines davon zu installieren. Daher kann ich an dieser Stelle nicht näher darauf eingehen.
Nun öffnest Du die Datei z.B. mit KWrite und weist den Tasten die gewünschte Funktion zu. Dabei kann jeder beliebige Linux-Befehl verwendet werden. Um mit der E-Mail-Taste z.B. das Programm KMail aufzurufen, müsste die entsprechende Zeile so aussehen:

mail = "kmail"

Einfach, oder nicht? Um mit vorhandenen Player-Steuerungstasten z.B. Xmms bedienen zu können, muss man die entsprechenden Befehle kennen:

"xmms --rew" springt zum vorigen Titel
"xmms --fwd" springt zum nächsten Titel
"xmms --play-pause" Wiedergabe starten/pausieren
"xmms --stop" Wiedergabe stoppen


Ebenfalls noch interessant bei vorhandenen Lautstärkereglern:

"EAK_VOLDOWN" lauter
"EAK_VOLUP" leiser
"EAK_MUTE" Stummschaltung


Wenn alles zu Deiner Zufriedenheit eingetragen ist, speicherst Du die Datei wieder ab. Nun muss LinEAK noch neu gestartet werden, damit die Änderungen auch greifen. Dies geschieht durch Eingabe des Kommandos

/usr/local/bin/lineakd restart


Und nun heißt es ausprobieren, ob alles wie gewünscht funktioniert - zur Not müssen die letzten Schritte eben so lange wiederholt werden, bis Alles passt - vor allem nie vergessen, nach einer Änderung an der Konfigurationsdatei das Programm neu zu starten.
Wenn dann Alles tutet, fehlt nur noch eine Sache: Du musst dafür sorgen, dass LinEAK beim Systemstart geladen wird. Dafür gibt es mehrere Möglichkeiten, ich habe es in bester Windows-Manier durch einen symbolischen Link im Autostart-Ordner von KDE gelöst.
Dieser wird erzeugt durch

ln -s /usr/local/bin/lineakd /home/<username>/.kde/Autostart

Es geht natürlich auch grafisch per Drag&Drop mit dem Konqueror oder einem anderen Dateimanager, aber wo wir die Konsole doch ohnehin gerade noch offen haben ;)

Damit bin ich vorerst am Ende und hoffe, ich konnte Dich mit diesem Tipp Deinem vollkommenen Linux-Glück wieder ein Stückchen näher bringen.

Pennywise
11.02.03, 18:16
Cool, da kann ich ja endlich die Tasten die ich unter Windows nicht nutze auch unter Linux nicht nutzen. :D

Supernature
11.02.03, 18:25
Ich tipp mir die Finger wund, und Du spuckst einfach drauf :heul
Spass beiseite, über Sinn und Unsinn lässt sich sicher trefflich streiten. Die Lautstärkeregulierung und die Player-Steuerung haben mir aber schon gefehlt.

Hans- Peter
12.02.03, 15:42
Original geschrieben von Pennywise
Cool, da kann ich ja endlich die Tasten die ich unter Windows nicht nutze auch unter Linux nicht nutzen. :D

Hehe, genau das habe ich gedacht, als ich Supi's erste Zeilen gelesen habe. :D :D :D

...aber ich habe es schon mal ausprobiert, es geht.

anonym
08.07.03, 21:31
hat mir sehr geholfen danke!
jetzt kann ich endlich mein MS MultiMedia Keyboard mit meinem lieben Gentoo nutzen ^^

big thanx!!

Supernature
08.07.03, 21:57
na, immerhin, wenigstens Einem hat es was gebracht :)

Pidi
30.07.03, 14:16
Hey,
ich möcht auch in diesen genuss kommen....:)

allerdings kommt bei mir bei ./configure eine fehlermeldung:
--------schnipp-------
checking for X... no
configure: error: You must have X installed
--------schnapp------

was will er mir damit sagen??? welches x fehlt ihm???

mein system ist :
debian woody
kde3.1.2

gruß Pidi

Pidi
30.07.03, 14:51
hat sich schon erledigt...mir fehlte die xlibs-dev.

aber wird meine Tastatur auch unterstüzt???
ich hab mir von aldi die neue Funktastatur geholt. (Medion md5351)
hab ich ne chanche die 19 zusatztasten zu benutzen???

gruß Pidi

Raven-Network
08.08.03, 12:19
Hallo !

Zuerst einmal vielen Dank für die Info und die Anleitung!
Genau sowas habe ich gesucht!

Und ich dachte, dass ich mein gutes Keyboard den Hasen geben kann.
Ich nutze zwar auch nur die Playerfunktionen aber das reicht ja auch ;)

So, ich werde es nunmal testen und mich dann nochmal melden.

Gruß FRANK

rockin_santa
28.08.03, 00:46
Hi zusammen,

ich hab die identische fehlermeldung wie Pidi, benutze aber suse8.1 und wollte fragen, ob bei suse überhaupt die gleiche bibliothek funktioniert und wie ich sie installiert bekomme. falls nicht, gibt es eine methode, um rauszufinden, woran es scheitert? (bin leider kein guru, der jede zweite kryptische logzeile als spam betrachtet).

rockin_santa

Supernature
28.08.03, 07:53
Schau doch mal, ob xlibs-dev bei SuSE dabei ist - wenn Du die "Professional"-Version hast, sollte das eigentlich der Fall sein.

rockin_santa
29.08.03, 21:11
ich habe es erfolgreich installiert gekriegt, allerdings kann ich nicht

lineakd restart

ausführen. er gibt mir dann die fehlermeldung:

...oops! error during CD-ROM init

merkwürdig :-(

weiss jemand, woran das liegen kann?

Supernature
29.08.03, 21:14
CD-ROM? :eek
Ne, keinen Plan - versuch es mal mit
lineakd stop
lineakd start
geht es so?

spacesonic
21.10.03, 11:15
Ich habe Lineak installiert und Volumen und Player funktionieren. (Habe die Medion MD5351 Tastatur und Suse 8.2)
Eine Frage hätte ich zu den Tasten für den Browser. Was muß ich hier eintragen ? mozilla --help erzählt mir leider nicht viel dazu.
Auch für den Sleepmodus wäre ich für eine Idee dankbar.

Vielen Dank im Vorraus

Supernature
21.10.03, 11:38
Ich weiß es gerade nicht auswendig - aber "mozilla -P" startet meines Wissens den Browser mit dem Standardprofil.

Gästele
12.12.03, 21:21
Also, ich krieg beim installieren unter Suse 9.0 Pro die Fehlermeldung, dass folgendes fehlt:
libxosd2
xosd
libxosd.so.2
Was soll ich tun?

Supernature
13.12.03, 10:47
installieren :D - geht auch ganz einfach, dürfte alles bei SuSE dabei sein. Gehe in YAST auf Software installieren, und benutze dann die Suche, um die Pakete zu finden.

DaMSt
20.02.04, 16:07
Hi,

also wenn ich ./configure make make install eingebe kommt:

configure: WARNING: you should use --build, --host, --target
configure: WARNING: you should use --build, --host, --target
configure: WARNING: you should use --build, --host, --target
checking build system type... Invalid configuration `make': machine `make' not recognized
configure: error: /bin/sh admin/config.sub make failed

bei dem Befehl ./configure --prefix=/usr --sysconfdir=/etc kommt:

checking build system type... i686-pc-linux-gnuoldld
checking host system type... i686-pc-linux-gnuoldld
checking target system type... i686-pc-linux-gnuoldld
checking for a BSD-compatible install... /usr/bin/install -c
checking for -p flag to install... yes
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for style of include used by make... GNU
checking for gcc... no
checking for cc... no
checking for cc... no
checking for cl... no
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details.

kann mir da wer weiterhelfen. kurz gesagt er installierts nich :(

greetz,

DaMSt

Supernature
20.02.04, 16:32
"Er" sagt Dir aber auch warum ;)
Ohne Compiler geht natürlich nichts - gcc dürfte bei den meisten Distris enthalten sein, das musst Du zuerst nachinstallieren.

DaMSt
20.02.04, 22:10
hm, *peinlich*

danke, werd ihn gleich mal installieren :)

greetz,

DaMSt

DaMSt
20.02.04, 22:37
ok, hab nun den compiler und X installiert..

wenn ich nun 'lineakd -l' eingebe, kommt folgendes:

lineakd: error while loading shared libraries: liblineak.so.0: cannot open shared object file: No such file or directory


mag da was bei der installation schief gelaufen sein? ich mein zwischendurch mal gelesen zu haben, das ich für irgendwas keine zugriffsrechte habe :-/

Danke übrigens für die Hilfe, ist nicht mehr selbstverständlich im Netz :)

greetz, DaMSt

Supernature
21.02.04, 00:35
Wozu sind wir denn da :)
Hast du "make install" evt. nicht als Root ausgeführt? Dann rattert die Prozedur durch und tut nichts. In dem Fall kannst Du es einfach nochmal wiederholen.
Wenn es das nicht war, dann müsste man schon die genauen Fehlermeldungen kennen, um etwas sagen zu können.

Pacemaker
16.07.04, 18:31
@Supernature

Hallo

Ich habe ein Problem beim installieren von lineakd, bzw. beim kompilieren.
Bei make treten Fehler auf mit denen ich nix anfangen kann.
Ich poste mal die ganze Ausgabe



make all-recursive
make[1]: Entering directory `/root/Downloads/lineakd-0.8beta3'
Making all in lineak
make[2]: Entering directory `/root/Downloads/lineakd-0.8beta3/lineak'
source='pluginmanager.cpp' object='pluginmanager.lo' libtool=yes \
depfile='.deps/pluginmanager.Plo' tmpdepfile='.deps/pluginmanager.TPlo' \
depmode=gcc3 /bin/sh ../admin/depcomp \
/bin/sh ../libtool --silent --mode=compile --tag=CXX g++ -DHAVE_CONFIG_H -DCONFDIR=\"/usr/local/etc\" -DPLUGINDIR=\"/usr/local/lib/lineakd/plugins\" -I. -I. -I.. -I../lineakd -I. -I.. -Wnon-virtual-dtor -Wno-long-long -Wundef -Wall -pedantic -W -Wpointer-arith -Wmissing-prototypes -Wwrite-strings -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -O2 -fno-exceptions -fno-check-new -c -o pluginmanager.lo `test -f 'pluginmanager.cpp' || echo './'`pluginmanager.cpp
source='globals.cpp' object='globals.lo' libtool=yes \
depfile='.deps/globals.Plo' tmpdepfile='.deps/globals.TPlo' \
depmode=gcc3 /bin/sh ../admin/depcomp \
/bin/sh ../libtool --silent --mode=compile --tag=CXX g++ -DHAVE_CONFIG_H -DCONFDIR=\"/usr/local/etc\" -DPLUGINDIR=\"/usr/local/lib/lineakd/plugins\" -I. -I. -I.. -I../lineakd -I. -I.. -Wnon-virtual-dtor -Wno-long-long -Wundef -Wall -pedantic -W -Wpointer-arith -Wmissing-prototypes -Wwrite-strings -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -O2 -fno-exceptions -fno-check-new -c -o globals.lo `test -f 'globals.cpp' || echo './'`globals.cpp
source='displayctrl.cpp' object='displayctrl.lo' libtool=yes \
depfile='.deps/displayctrl.Plo' tmpdepfile='.deps/displayctrl.TPlo' \
depmode=gcc3 /bin/sh ../admin/depcomp \
/bin/sh ../libtool --silent --mode=compile --tag=CXX g++ -DHAVE_CONFIG_H -DCONFDIR=\"/usr/local/etc\" -DPLUGINDIR=\"/usr/local/lib/lineakd/plugins\" -I. -I. -I.. -I../lineakd -I. -I.. -Wnon-virtual-dtor -Wno-long-long -Wundef -Wall -pedantic -W -Wpointer-arith -Wmissing-prototypes -Wwrite-strings -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -O2 -fno-exceptions -fno-check-new -c -o displayctrl.lo `test -f 'displayctrl.cpp' || echo './'`displayctrl.cpp
displayctrl.cpp: In member function `displayCtrl::displayCtrl(LConfig&)':
displayctrl.cpp:32: warning: unused parameter `LConfig&config'
displayctrl.cpp: In member function `virtual void displayCtrl::volume(float)':
displayctrl.cpp:57: warning: unused parameter `float volume'
displayctrl.cpp: In member function `virtual void displayCtrl::init(LConfig&)':
displayctrl.cpp:37: warning: unused parameter `LConfig&config'
source='xmgr.cpp' object='xmgr.lo' libtool=yes \
depfile='.deps/xmgr.Plo' tmpdepfile='.deps/xmgr.TPlo' \
depmode=gcc3 /bin/sh ../admin/depcomp \
/bin/sh ../libtool --silent --mode=compile --tag=CXX g++ -DHAVE_CONFIG_H -DCONFDIR=\"/usr/local/etc\" -DPLUGINDIR=\"/usr/local/lib/lineakd/plugins\" -I. -I. -I.. -I../lineakd -I. -I.. -Wnon-virtual-dtor -Wno-long-long -Wundef -Wall -pedantic -W -Wpointer-arith -Wmissing-prototypes -Wwrite-strings -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -O2 -fno-exceptions -fno-check-new -c -o xmgr.lo `test -f 'xmgr.cpp' || echo './'`xmgr.cpp
xmgr.cpp: In function `static int Xmgr::Xhandler(Display*, XErrorEvent*)':
xmgr.cpp:67: warning: unused parameter `Display*theDisplay'
source='cdromctrl.cpp' object='cdromctrl.lo' libtool=yes \
depfile='.deps/cdromctrl.Plo' tmpdepfile='.deps/cdromctrl.TPlo' \
depmode=gcc3 /bin/sh ../admin/depcomp \
/bin/sh ../libtool --silent --mode=compile --tag=CXX g++ -DHAVE_CONFIG_H -DCONFDIR=\"/usr/local/etc\" -DPLUGINDIR=\"/usr/local/lib/lineakd/plugins\" -I. -I. -I.. -I../lineakd -I. -I.. -Wnon-virtual-dtor -Wno-long-long -Wundef -Wall -pedantic -W -Wpointer-arith -Wmissing-prototypes -Wwrite-strings -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -O2 -fno-exceptions -fno-check-new -c -o cdromctrl.lo `test -f 'cdromctrl.cpp' || echo './'`cdromctrl.cpp
In file included from /usr/include/linux/byteorder/little_endian.h:11,
from /usr/include/asm/byteorder.h:59,
from /usr/include/linux/cdrom.h:14,
from cdromctrl.cpp:33:
/usr/include/linux/byteorder/swab.h: In function `__u16 __fswab16(short
unsigned int)':
/usr/include/linux/byteorder/swab.h:135: error: ISO C++ forbids braced-groups
within expressions
/usr/include/linux/byteorder/swab.h:135: error: ISO C++ forbids braced-groups
within expressions
/usr/include/linux/byteorder/swab.h: In function `__u16 __swab16p(__u16*)':
/usr/include/linux/byteorder/swab.h:139: error: ISO C++ forbids braced-groups
within expressions
/usr/include/linux/byteorder/swab.h:139: error: ISO C++ forbids braced-groups
within expressions
/usr/include/linux/byteorder/swab.h: In function `void __swab16s(__u16*)':
/usr/include/linux/byteorder/swab.h:143: error: ISO C++ forbids braced-groups
within expressions
/usr/include/linux/byteorder/swab.h:143: error: ISO C++ forbids braced-groups
within expressions
make[2]: *** [cdromctrl.lo] Error 1
make[2]: Leaving directory `/root/Downloads/lineakd-0.8beta3/lineak'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/root/Downloads/lineakd-0.8beta3'
make: *** [all] Error 2


Kannst du mir helfen ?

Supernature
16.07.04, 18:41
Sorry, muss passen.
Aber bestimmt kann jemand anders was dazu sagen.

Viper
17.07.04, 16:54
@Pacemaker

Es gibt zwei Möglichkeiten:

1) Die Installation ging aufgrund eines Bugs nicht

--> neue version besorgen

2) Die Installation ging nicht weil du es falsch kompiliert hast

entpacke als erstes die Quellen
tar -jxvf (bzip) tar -zxvf (gz)

dann ins verzeichnis wechseln
./configure
make
und als root make install

Pacemaker
19.07.04, 17:50
Also ich habe es hinbekommen :D

Ich hatte zuerst die neuste Beta genommen und bei der ging´s nicht.
Dann habe ich lineakd 0.7.2 genommen und da war das kompilieren ein Kinderspiel. ;)

Nochwas:

Ich habe ja einen Laptop Sony Vaio PCG-FR215H
Da habe ich folgende Konfiguration genommen:


[CIK13]
brandname = "Compaq"
modelname = "Internet Keyboard (13 keys)"


Also trotzdem danke an euch für diese Programmempfehlung. :)

steppenwolf
26.07.04, 19:35
hi
ich hab 2 soundkarten(bzw eine soundkarte und ein onboardchip) in meinem system. mithilfe der sondertastenbelegung von lineakd (z.b. "EAK_VOLUP") kann ich die lautstärke der einen verändern. weiß zufällig jemand was ich für einen befehl ich eingeben muss um die andere anzusteuern um deren lautstärke zu verändern.

gruß
steppenwolf

Viper
26.07.04, 21:24
man lineakd

Da stehts drin, wie du mehrere Soundkarten mit Lineakd "bearbeiten" kannst.

steppenwolf
27.07.04, 12:45
@Slackware:~$ man lineakd
No manual entry for lineakd

gibts da überhaupt eine manpage?

gruß
steppenwolf

Viper
28.07.04, 20:58
Seltsam. Ich habe eine Manpage:

hier ist der ausschnitt mit deinem Problem:

Macros
lineakd supports 5 Macros. Since lineakd 0.7 macros can also take one
or more arguments.

Macro definitions are as follows.

For the EAK_MUTE macro. We have three forms that are acceptible.

EAK_MUTE
This is the default and original macro form. In this form you
require a directive in your config file in order for the macro
to know which mixer device to adjust. e.g. MixerDevice =
/dev/mixer

EAK_MUTE(X)
Here X is a number. The number is a volume to mute to. Currently
this needs revisiting. If the number is too low it will merely
change the balance. I suggest a value around 10000. I will fix
this later so that it's a relative value from the minimum. In
this form you require a directive in your config file in order
for the macro to know which mixer device to adjust. e.g. Mix-
erDevice = /dev/mixer

EAK_MUTE(X,device,X2,device2,X3,device3,...)
X is a volume to mute to, and device is a string name of a mixer
device (e.g. "/dev/mixer" to mute to. As with the previous
macro, you will have to experiment with a good value.

For the EAK_VOLUP and EAK_VOLDOWN macros. Each have the following three
forms.

EAK_VOLUP or EAK_VOLDOWN
Increment or decrement the sound by the default amount. In this
form you require a directive in your config file such as: Mix-
erDevice = /dev/mixer in order for the macro to know which mixer
device to adjust.

EAK_VOLUP(X) or EAK_VOLDOWN(X)
Increment or decrement the sound by X. This value is best used
between 1 and 5, and the sound modification code scales the
value, unlike the MUTE macro. In this form you require a direc-
tive in your config file such as: MixerDevice = /dev/mixer in
order for the macro to know which mixer device to adjust.

EAK_VOLUP(X,device,X2,device2,X3,device3,...) or
EAK_VOLDOWN(X,device,X2,device2,X3,device3,...)
X is the volume to adjust the following device by. Like the pre-
vious form of this macro, a value of 1-5 is best.

For the EAK_EJECT macros. There are two forms.

EAK_EJECT
This is the default macro. It will eject the device defined in
your config file as: CdromDevice = /dev/cdrom

EAK_EJECT(device1,device2,device3,...)
This macro form allows you to choose the device to eject. You
can have a list of one or more devices separated by a comma.

For the EAK_SLEEP macro. It currently does nothing. In the future I
will probably use it to invoke software suspend.

For the EAK_SCREEN_LOCK macro. There is only one form.
EAK_SCREEN_LOCK(X) Where X is either KDE, GNOME or XSCREENSAVER
The values GNOME or XSCREENSAVER do the same thing. They invoke
the Xscreensaver program to lock the desktop.

poisonmarc123
15.10.04, 02:18
Hallo! Meine Tastatur wird laut Liste unterstützt. Doch nun weiß ich nicht weiter.
Meine Fehlermeldung lautet:

Cannot open display :0.0
Could not open the display. Exiting
Tux:/usr/bin # lineakd start
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified


Ich nutze SuSE 9.0 - bin Neuling und habe somit keine Ahnung von Linux - Kann ich RPMs von allen Distributionen installieren? Was bedeutet i386, i586 et cetera in den Paketen? - Irgendwie habe ich noch keinen Peil...


... bei Windxxx war es für mich etwas leichter - damit bin ich sozusagen aufgewachsen - ab Dos 5.* über alle Win - und nun zu Linux - mein zweiter Versuch - diesmal motivierter (Buch bzw. Wälzer über Linux gekauft)

LG
poisonmarc123

Supernature
15.10.04, 08:01
Du kannst ein RPM-Paket nur für die Distribution nutzen, für die es erstellt wurde. Es kann auch auf anderen Distris funktionieren, muss aber nicht. Ich empfehle Dir bei diesem Tool die Installation von Hand, sie ist nicht sehr kompliziert und oben ja auch gut(?) beschrieben.

Bio-logisch
15.10.04, 08:28
Original geschrieben von poisonmarc123
Hallo! Meine Tastatur wird laut Liste unterstützt. Doch nun weiß ich nicht weiter.
Meine Fehlermeldung lautet:

Cannot open display :0.0
Could not open the display. Exiting
Tux:/usr/bin # lineakd start
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified


Ich nutze SuSE 9.0 - bin Neuling und habe somit keine Ahnung von Linux - Kann ich RPMs von allen Distributionen installieren? Was bedeutet i386, i586 et cetera in den Paketen? - Irgendwie habe ich noch keinen Peil...

Die Fehlermeldung deutet darauf hin, dass Du den Prozess nicht als den Benutzer starten willst, mit dem Du gerade angemeldet bist (also z.B. mit su über eine Konsole).

i386: Paket läuft auf allen Rechnern ab 386er Prozessor
i586: Paket läuft auf allen Rechnern mit Pentium 1 oder besser

MfG, Bio-logisch

poisonmarc123
15.10.04, 17:05
Hallo!
Danke Euch - jetzt läuft alles!!!
Ich war als falscher user drin und deshalb funzte es nicht.
Danke auch für die anderen Antworten - Linux-neulinge können ab und an etwas nerven, denke ich https://www.supernature-forum.de/images/icon/icon12.gif

Meine 100000000 anderen Fragen stelle ich euch dann in nächster Zeit https://www.supernature-forum.de/images/icon/icon10.gif

Wünsche Euch einen schönen Tag
Ciao
poisonmarc123

poisonmarc123
16.10.04, 22:08
Hallo!
Anbei eine Beispielkonfiguration von meiner Tastatur. Eventuell kann ich jemandem damit etwas weiterhelfen?!?
Vielen Dank übrigens für die gute(!) Beschreibung, wie man diese Tastaturen einrichtet!!!
Da ein key in der Originalform nicht funktionierte habe ich ihn korrigiert und noch einige Tasten ergänzt und nach meinem Gefallen übersetzt:

*** lineakkb.def ***

LTAK]
brandname = "Logitech"
modelname = "Access Keyboard"
[KEYS]
Schlafen = 223
Email = 236
Messenger = 145
Webkamera = 146
Startseite = 178
Suche = 229

Stumm = 160
LautstaerkeP = 176
LautstaerkeM = 174
Media = 237
vorheriger = 144
folgender = 153
Start/Pause = 162
Stop = 164

Neu = 187
Antworten = 188
naechster = 118
Senden = 119

MeinPC = 195
MeineDokumente = 196
MeineBilder = 215
MP3 = 216

WinStart = 115 <-- Ergänzungen ab hier!!!
WinStart. = 116
KDEsys = 117

DruckSAbf = 111
Rollen = 78
Pause = 110

[END KEYS]
[END LTAK]

*** lineakd.conf ***

# LinEAK - Linux support for Easy Access and Internet Keyboards
# Copyright (c) 2001,2002, 2003 Sheldon Lee Wen <leewsb@hotmail.com>
# and Mark Smulders <Mark@PIRnet.nl>
# http://lineak.sourceforge.net
#
# lineakd configuration file
#
# example key configuration:
# play = "xmms --play-pause"
# eject = EAK_EJECT
#
# available special actions:
# EAK_EJECT
# EAK_VOLUP
# EAK_VOLDOWN
# EAK_MUTE
# EAK_SLEEP
#

KeyboardType = LTAK
CdromDevice = /dev/cdrom
MixerDevice = /dev/mixer
Screensaver = _null_
XOSD_font = -adobe-helvetica-bold-r-normal-*-*-240-*-*-p-*-*-*
XOSD_color = 0aff00
XOSD_timeout = 3
XOSD_pos = bottom
XOSD_align = center
XOSD_hoffset = 0
XOSD_voffset = 50
XOSD_soffset = 1

Email = "kmail"
naechster = ""
Media = "gmplayer"
Stumm = "EAK_MUTE"
MeinPC = "kfmclient openProfile filemanagement"
MeineDokumente = "" <-- Leider weiß ich nicht, wie man auf eigene Ordner zugreift ;-(
Startseite = "mozilla www.web.de"
MP3 = ""
MeineBilder = ""
Neu = "kmail --composer" <-- Schnellversand einer email
folgender = "xmms --fwd"
Start/Pause = "xmms --play-pause"
vorheriger = "xmms --rew"
Antworten = ""
Messenger = "kopete"
Suche = "mozilla www.google.de"
Senden = ""
Schlafen = "logout" <-- noch nicht getestet!!!
Stop = "xmms --stop"
KDEsys = "ksysguard" <-- Taskbutton öffnet KDE Systemüberwachung
LautstaerkeM = "EAK_VOLDOWN"
LautstaerkeP = "EAK_VOLUP"
Webkamera = "ksnapshot" <-- Habe keine Cam also: Bildschirmphoto
WinStart = "" <-- Hiermit soll die WinStart-Taste mit dem KDE-Start verknüpft
WinStart. = "" werden. Doch auch hier fehlt mir der Befehl.
DruckSAbf = ""
Rollen = ""
Pause = ""


# end lineakd.conf

Meine Fragen:
1. Wie kann ich auf eigene Ordner zugreifen?
2. Kann ich den KDE-Startknopf mit der Windows Taste verknüpfen? Wie?

Ich hoffe, dass jemand etwas damit anfangen und mir ggf. Tips zu meinen noch offenen Fragen geben kann. Alles ohne Gewähr und auf eigene Gefahr...

Bis denne
poisonmarc123

Bio-logisch
16.10.04, 22:16
1.) Der Filemanager von KDE heist konqueror. Du kannst einfach den Pfad zum gewünschten Verzeichniss als Parameter mit aufrufen.

2.) Weiß ich auch nicht.
Das K - Menü wird mit der Tastenkombination ALT + F1 aufgerufen.

poisonmarc123
17.10.04, 00:17
Das einzige, was ich in den Tiefen des www herausfinden konnte ist folgendes:

dcop kicker kicker popupKMenu 0

Dieser Befehl öffnet das K-Menü jedoch an der telle wo sich die Maus befindet. Ich denke, dass es irgendeinen BEfehl geben wird, der die Position des Fensters zuweist!?!

Eventuell weiß jemand Rat

LG
poisonmarc123

Bio-logisch
17.10.04, 00:25
Wie gesagt, keine Ahnung. Mit KDE habe ich mich nie näher beschäftigt, ich benutze meißtens Windowmaker.

poisonmarc123
18.10.04, 00:44
Hallo!
Habe mal im Web geforscht, wie man das K-Menü positionieren kann. Mögliche User können dies bei Interesse in folgender Datei einbinden:

*** lineakd.def ***
Email = "kmail" (Alternativ: --check =hole emails / --composer = schreibe emails)
...
MeinPC = "kfmclient openProfile filemanagement" <-- öffnet persönliches Verzeichnis
...
Startseite = "mozilla www.easy-linux.de" <-- öffnet den Browser Mozilla auf der angegebenen Internetseite
...
MeineBilder = "konqueror /Bilder" <-- öffnet auf dem eigenen System den angegebenen Ordner
...
WinStart = "dcop kicker kicker popupKMenu 1,424" <-- Dieser Eintrag positioniert das K-Menü an der "gewohnten" Stelle.

Mit den Werten des K-Menüs kann man etwas spielen: Der Wert 1,1 positioniert es links oben - der Wert 1,2000 links unten...
Also ausprobieren was einem besser zusagt.

Wer es genau nachlesen möchte: http://llistes.bulma.net/pipermail/bulmailing/Week-of-Mon-20031110/031955.html

LG
poisonmarc123

Bio-logisch
18.10.04, 09:41
Danke für das ausführliche Posting!
Das kann sich noch jemand verwenden!

MfG, Matthias

Gast08154711
23.10.04, 01:51
Fettes Lob an poisonmarc123, bio-logisch und supernatre. Mit euren Antworten läuft mein keyboard jetzt auch unter Linux!!! Außerdem habe ich jetzt wieder mein "Windows-Start-Menü" :-))

Thorsten

Stephan1965
28.11.04, 14:02
Hallo zusammen,
ich habe lineak installiert und es läuft auch ganz gut. Audiosteuerung bereitet keine Probleme, Kmail und Konqueror startet auch.
Wenn ich allerdings mit meinem Keyboard die "Rechner"-Taste drücke, bekomme ich KCalc nicht gestartet. Wie muß ich den Befehl für das Starten eines beliebigen Programms (hier Calculator) in lineak eintragen, damit es läuft? Ich hatte in KLineakConfig unter "Befehl ausführen" einfach KCalc eingetragen. Leider funktioniert das nicht.
Die Sachen, die bei mir funktionieren, sind bei Lineak als Makro abgelegt. Hängt es damit zusammen?

Bio-logisch
28.11.04, 14:08
Hast Du die Groß/Kleinschreibung beachtet? Linux ist case - sensitiv, es unterscheidet da pedantisch genau.
Daher werden die Befehle zum Aufruf eines Programmes fast immer klein geschrieben.

Stephan1965
28.11.04, 20:37
Groß- und Kleinschreibung! Das war es. Vielen Dank!

danielgww
28.05.05, 13:50
Super Beschreibung. Ich hab alles so gemacht wie in der Beschreibung angegeben. Es klappt auch soweit. Nur die Befehle (EAK_MUTE; EAK_VOLUP; E
AK_VOLDOWN) gehen nicht. Hat jemand eine ahnung woran das liegt? Ich benutze Suse 9.3


# LinEAK - Linux support for Easy Access and Internet Keyboards
# Copyright (c) 2001,2002, 2003 Sheldon Lee Wen <leewsb@hotmail.com>
# and Mark Smulders <Mark@PIRnet.nl>
# http://lineak.sourceforge.net
#
# lineakd configuration file
#
# example key configuration:
# play = "xmms --play-pause"
# eject = EAK_EJECT
#
# Lineakd supports the following modifier keys:
# control alt shift mod2 mod3 mod4 mod5

CdromDevice = /dev/cdrom
Display_align = center
Display_color = 0aff00
Display_font = -adobe-helvetica-bold-r-normal-*-*-240-*-*-p-*-*-*
Display_hoffset = 0
Display_plugin = internal
Display_pos = bottom
Display_soffset = 1
Display_timeout = 3
Display_voffset = 50
KeyboardType = ACE-TM290
MixerDevice = /dev/mixer
RAWCommands =
Screensaver =
conffilename = /home/komander/.lineak/lineakd.conf
keystate_capslock =
keystate_numlock =
keystate_scrolllock =

AudioLowerVolume = "EAK_VOLDOWN"
AudioMute = "EAK_MUTE"
AudioRaiseVolume = "EAK_VOLUP"
Mail = "evolution"
Sleep = "konqueror /home/komander/daten"
WWW = "firefox"

Supernature
28.05.05, 23:32
Hallo und willkommen :hallo
Ich fühle mich zur Antwort "verpflichtet", weil die Anleitung ja ursprünglich von mir war. Leider habe ich mich von dem Thema wieder ziemlich weit entfernt und kann daher nicht helfen, aber vielleicht hat jemand anders eine Idee?

Bio-logisch
28.05.05, 23:45
Ich benutze das Programm zwar auch nicht mehr, aber wenn ich mich recht entsinne, dann gab es doch immer zwei Config-Dateien:

Eine, in der die Funktionen einem Befehl zugeordnet wurden, und eins, wo diese Befehle mit einer Taste belegt wurden.
Erster Verdächtiger: Irgendwelche Fehler in der Groß/Kleinschreibung oder so.

Da aber alle Funktionen mit dem Audiosystem zusammenhängen, könnte man sich auch das mal genauer ansehen.

danielgww
29.05.05, 00:52
@Bio-logisch
wo soll diese 2. Datei sein?
Ich habe auch alles auf GroßKleinschreibung kontroliert, scheint nicht daran zu liegen.
Was kann das noch sein.