PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Verzeichnis-Freigabe mit Samba unter SuSE Linux 8.1



Pennywise
08.12.02, 11:36
Hier wird erklärt wie einzelne Verzeichnisse auf Linuxrechnern auf wohl einfachsten Weg in einem Windowsnetzwerk freigegeben werden. Das Netzwerk muss hierfür selbstverständlich schon korrekt installiert sein.

Von der Kommandozeile halten wir uns fern, auch wenn Profis wohl die Nase rümpfen dürften. Ebenso werde ich mich nicht tiefgreifend mit Samba beschäftigen, da einerseits der Beitrag wohl zu lang würde und ich andererseits auch kaum Ahnung habe. :lol
Vielmehr will ich totalen Anfängern (wie mir) bei den ersten Hürden helfen um wenigstens eimal eine "grobe" Verbindung zu erhalten und nicht schon durch nicht aktivierte Dienste oder andere Kleinigkeiten deprimiert zu werden. :)
Ich erhebe keinen Anspruch auf Korrektheit und bitte eventuelle Fehler zu melden, damit ich sie korrigieren kann. Weiterführende Informationen dürfen natürlich angehängt werden.



Für folgende Aktionen loggen wir uns als root ein

Um Samba nutzen zu können müssen die nötigen Pakete unter YAST2 natürlich installiert werden. In der Paketauswahl das Paket Samba suchen und auf die Festplatte kopieren.

Um Samba menügeführt konfigurieren zu können müssen wir das Tool swat aktivieren. Hierfür müssen wir die Datei /etc/inetd.conf öffnen und darin nach folgenden Eintrag suchen:
# swat stream tcp nowait.400 root /usr/sbin/swat swatHier entfernen wir das #-Zeichen am Anfang um den Eintrag aktiv zu schalten. Danach speichern wir die Datei wieder ab.

Als nächstes werden wir Einstellungen vornehmen um die benötigten Dienste beim Bootvorgang automatisch zu starten.
Wir öffnen YAST2 / Sytem / Runlevel-Editor, dort klicken wir auf den Button Runlevel-Eigenschaften.
Nun suchen wir in der Liste folgende Einträge:

inetd
nmb
smb

Bei allen drei Einträgen aktivieren wir die Checkboxen 3 und 5 um die Dienste automatisch beim Systemstart (3 für Netzwerkberieb im Textmodus, 5 für Betrieb unter KDE) zu starten. Die Menüs mit Beenden schließen - YAST2 aktualisiert die Konfigurationsdateien selbstständig. Um weitere manuelle Eingriffe zu vermeiden starten wir Linux einmal komplett neu.

Frisch gestartet starten wir einen Webbrowser und tippen in die Adresszeile localhost:901 ein. Swat verlangt nach root-Login, also root und zugehöriges Passwort eingeben.

Nun geht es an die Einstellungen:
Im Register GLOBALS wird bei Arbeitsgruppe der gewünschte Eintrag unseres Netzwerkes eingetragen
Unter SHARES geben wir im zweiten Eingabefeld den gewünschten Namen der Freigabe ein.

ACHTUNG: Dies ist nicht der Verzeichnisname, sondern nur die Bezeichnung unter der das später freigegebene Verzeichnis auf den Clients erscheint.

Nun mit dem Button Create Share bestätigen und somit einen neuen Eintrag erzeugen.
Im neu erstellten Eintrag müssen wir jetzt noch den Pfad des freizugebenden Verzeichnisses unter path also z.B. /tmp eintragen. Soll geschrieben werden können muss read-only auf no sein.

ACHTUNG: Der später vorgesehene User muss rechte im Dateisystem besitzen, d.h. er muss Besitzer, in der Gruppe der Datei sein oder die Datei muss für alle freigegeben sein, je nach Zugriffsart. Ist die Datei auf dem Linuxrechner nur für root frei kann man in Samba einstellen was man will, es wird nicht klappen. Ich schreibe das aus schmerzlicher Erfahrung. :lol

Das Ganze bestätigen wir noch mit dem Button Commit Changes

Nun müssen noch unter der Registerkarte PASSWORD berechtigte User hinzugefügt werden. Dazu geben wir den gewünschten Usernamen (dr auf dem Linuxsystem auch schon vorhanden sein muss) und sein Passwort mit Bestätigung ein und klicken erst auf Add New User, dann auf Enable User.

Zur Sicherheit starten wir den Linuxrechner nochmal neu, ebenso anschließend die Windows Clients. Nun sollte in der Arbeitsumgebung die neu erstellte Freigabe erscheinen.

Viel Glück! :D

fliwatue
18.06.03, 12:51
Herzlichsten Dank
Nun hab ich endlich die Grundlagen auf denen sich aufbauen lässt.

Nun muss ich nur noch rausfinden wie ich die Nutzernamen auf den Linux Rechner bringe .... :-)

Roady
02.07.03, 12:08
und wenn ich im Runlevel-Editor den Eintrag inetd nicht habe?

Was mache ich dann, liegt es an SuSE 8.2??

Sorry, bin absolute Linux-Neuling! ;-)

Gruß

Roady

Theoderix
03.07.03, 16:13
Hallo, ich hab die inetd.conf auch nicht , nur ne xinetd.conf ;)

Brauchst Du aber auch nicht ... galube ich .
Mach nur die nmb und smb Einstellung .

Damit es dann läuft mußte ich noch folgendes machen:

SuSE work menu (das mit dem Blitz)--->Administration--->YaST2 Module--->Netzwerkdienste--->Netzwerkdienste(inetd)--->

Aktivieren Radio Button klicken

swat suchen und auf Status wechseln an klicken ...

Neustart und der Swat läuft.

Gruß Theo

csjollyjoker
06.07.03, 18:13
Coole Anleitung! SWAT geht! Habe folgendes Problem: Habe ein Heimnetzwerk und möchte Dateien zur Verfügung stellen! Habe einen Ordner pub angelegt! Ich heisse im Netzwerk max und ein anderer client michi. Wie kann ich es so einstellen, dass michi nur lesen kann und ich auch Dateien in das Verzeichniss kopieren kann? Vielen Dank für Eure Hilfe!

conner
25.09.03, 12:40
Moin!
Das habe ich ja auch alles brav gemacht, User (smbshare) angelegt dann unter Swat geaddet und aktiviert, einen Namen 'transfer' vergeben und den Pfad /home/conner/download eingetragen. Das Verzeichnis download habe ich dann vorsichtshalber noch mit 777 belegt, also wenn das jetzt nicht frei ist...
Unter W2000 sehe ich dann den Rechner auch im Netzwerk und wenn ich draufklicke kommt:
'Auf \\Susi kann nicht zugegriffen werden. Mit diesem Konto kann man sich nicht von diesem Computer aus anmelden.'
Wenn ich das ganze über Extras Netzlaufwerk verbinden versuche passiert ähnliches:
NEtzlaufwerk verbinden \\Susi\transfer
unter dem Namen smbshare , passwort 123
'Das Netzlaufwerk konnte nicht verbunden werden, da der folgende Fehler aufgetreten ist:Mit diesem Konto kann man sich nicht von diesem Computer aus anmelden.'

Ach so, hoch und runtergefahren habe ich beide Kisten auch (von anderen Rechnern aus im NEtz passiert das gleiche?)

Wäre toll wenn noch jemand eine Idee hätte... kann doch eigentlich nur noch eine Kleinigkeit sein oder?
(Hier noch die smb.conf:
)# Samba config file created using SWAT
# from 192.168.20.2 (192.168.20.2)
# Date: 2003/09/25 11:03:39

# Global parameters
[global]
workgroup = DOLCET
netbios name = SUSI
time server = Yes
unix extensions = Yes
socket options = SO_KEEPALIVE IPTOS_LOWDELAY TCP_NODELAY
printcap name = CUPS
character set = ISO8859-15
os level = 2
printing = cups
veto files = /*.eml/*.nws/riched20.dll/*.{*}/

[homes]
comment = Home Directories
valid users = %S
read only = No
create mask = 0640
directory mask = 0750

[printers]
comment = All Printers
path = /var/tmp
create mask = 0600
printable = Yes
browseable = No

[print$]
comment = Printer Drivers
path = /var/lib/samba/drivers
write list = @ntadmin root
force group = ntadmin
create mask = 0664
directory mask = 0775

[transfer]
path = /home/conner/download
guest account =
read only = No
guest ok = Yes
<schnapp>

und die smbusers, die mir ein wenig mager aussieht:

<schnipp>

# This file allows you to map usernames from the clients to the server.
# Unix_name = SMB_name1 SMB_name2 ...
#
# Cf. section 'username map' in the manual page of smb.conf for more
# information.

;root = administrator admin
;nobody = guest pcguest smbguest

<schnapp>

Wobei ich nicht glaube die zu brauchen?!
Dankbar für Hilfe!
Gruß Conner :eek

conner
26.09.03, 10:59
Moin!
Ich gehe mal davon aus, dass es von allgemeinem Interesse sein könnte, warum das nicht geklappt hat bei mir, das Problem könnten ja noch andere bekommen:
Mein Samba Server steht in einem Peer to Peer Netz, daher muß der security Parameter auf share gesetzt werden und da die Clients, die auf den Server wollen in meinem Fall alles W2K und XP Kisten sind ist daher Passwortverschlüsselung gefordert, d.h. encrypt passwords muss yes sein.
Das sieht dann so aus:

<schnipp>

[global]
..
..
..
security = share
..
..
encrypt passwords = yes
..


[homes]
comment = Home Directories
valid users = %S
read only = No
create mask = 0640
directory mask = 0750

[printers]
..
..

[print$]
..
..

[transfer]
path = /home/conner/download
guest account =
read only = No
guest ok = Yes

<schnapp>

Das reicht dann für meine derzeitigen Bedürfnisse erstmal aus. Und vielen Dank an Pennywise!

Gruß Conner :funny

tispokes
25.01.04, 13:09
ole es geht bei mir auch, kann mich auch als root einloggen von win aus mit net use x: blablabla
das einzige problem was ich ahbe ist:

ich kann nicht in den ordner root! wieso?


mfg tispokes

Buccaneer
25.01.04, 14:12
Normalerweise musst Du unter Samba die einzelnen Ordner freigeben, damit Du von einem Windowsrechner draufkannst :)...

Richte für so einen Fall unter Swat einfach ein neues Share ein, welches das Root Verzeichnis beherbergt.

little_nemo
13.12.04, 12:12
Hallo allerseits,

ich bin auch ein Linux-Neuling. Als solcher bin ich recht spät dazugekommen, habe also mit Suse 9.2 Professional erste Erfahrungen gesammelt. Gefällt mir bisher sehr gut! Darin gibt es bei Yast/Netzwerkdienste Samba-Client und Samba-Server, die sich beide ganz gut konfigurieren lassen. Ich brauchte also die obige Anleitung nicht.

Was den Zugriff angeht, so habe ich auch festgestellt, dass ich auf den Rechnernamen und die Freigabe nicht(!) zugreifen konnte, solange ich es mit Netzlaufwerk verbinden \\pcname\freigabename versuchte. In einer Anleitung stand, dass die Verbindung nur über TCI/IP aufgebaut wird. Und mit Netzlaufwerk verbinden \\ip.add.res.se\freigabename hat es geklappt.

:-) little_nemo

PS: Schaut mal nach unter http://www.handverlesenes.de/linux.htm.
Habs ausprobiert - hat funktioniert :-).

sascha86
27.03.06, 12:19
beim sürfen habe ich ne gute hilfe für eine einfache samba freigabe gefunden.
sambaconfig (http://chuky1986.ch.funpic.de/linux/samba/samba_conf.pdf)