PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : [Multimedia] Kann der Linux-MPlayer auch DivX und wmv?



Supernature
02.10.02, 11:53
Der neue MPlayer gefällt mir ganz gut und funktioniert auch hervorragend. Kann ich dem auch "beibringen", DivX-Avi's und wmv-Dateien abzuspielen?
Oder gibt es dafür andere Lösungen ?

--RAVEN--
02.10.02, 18:36
Kann er normalerweise. Nur die komische Version von SuSE kann es nicht. Er spielt alles ab, wenn er richtig eingerichtet ist. Ich setze mich da heute Abend mal dran und schreibe was dazu...

--RAVEN--
02.10.02, 20:22
Wie versprochen: Eine Anleitung um den MPlayer zu "kurieren"

Nun geht es los:

Mit Yast:
GTK installieren (alles was nach GTK und Develop aussieht),
make installieren
gcc installieren
gcc-c++ installieren
binutils installieren

Auf http://www.mplayerhq.hu/homepage/dload.html folgendes runterladen:

MPlayer v0.90pre8 source
Win32 codecs
Default Skin
Fonts & symbols package for OSD (ISO 8859-1)

Die Win32-Codecs entpacken, ein Textfensterchen in dem Verzeichnis öffnen,
"su" (wie SuperUser) eingeben, Root-Passwort. Dann "mv * /usr/lib/win32"
um die Dateien in das Verzeichnis zu verschieben. Unter Suse existiert es
zwar, ist aber leer, warum auch immer...

Nun im Home-Verzeichnis den Inhalt des (unsichtbaren) Verzeichnisses ".mplayer" löschen. Einen Ordner "Skin" in ".mplayer" anlegen, das "Default Skin"-Packet da hinein entpacken. Dabei wird der Ordner "Skin/Default" angelegt.

Für den Zeichensatz: In ".mplayer" das Verzeichnis "Font" anlegen und die ZIP-Datei da rein entpacken (legt einige Unter-Ordner an). Den Inhalt eines dieser Unterordner zum einen nach /.mplayer/font/ kopieren und zum anderen nach /usr/local/share/mplayer/font kopieren. Z.B. wenn man sich im Fontverzeichnis /arial-18/ befindet mittels cp * /usr/local/share/mplayer/font Man muss sich im Superuser-Modus befinden, da man sonst keine Schreibrecht auf /usr/... hat.

Nun die Mplayer-Datei in ein temporäres Verzeichnis entpacken. Dort ein Konsolenfenster öffnen, wieder in der SuperUser-Modus wechseln (mit su) und "./configure --enable-gui" eingeben. Das geht relativ flott.

Wenn keine Fehlermeldung erscheint, "make" zum kompilieren eingeben, ein paar Minuten (mehr ;)) warten, und schließlich "make install" zum installieren.

Die Fehlermeldungen geben in der Regel einen guten Aufschluß darüber, welche Programme noch fehlen. Falls es eine Fehlermeldung gibt, auf jeden Fall hier posten, damit anderen das von vorneherein nicht passiert. Es kann natürlich sein das ich etwas installiert habe, was MPlayer benötigt, aber nicht mit der Standard-Installation kommt, da ich bei der Installation von Suse gleich alles ausgesucht habe was ich so benötige...

Nebenbei: Jetzt haben wir die aktuellste Version des MPlayers und den noch auf den jeweiligen Prozessor optimiert, also wesentlich perfomanter, da auch MMX, MMX2, 3Dnow, SSE usw... genutzt wird.

Edit: kleinen Fehler mit dem Font behoben. Wenn man ihn nicht nach /usr/local/share/mplayer/font/ kopiert kommt bei mir mit bei jedem Start von MPlayer eine Fehlermeldung.

Frohes Movies schauen :D Ich hoffe bei euch klappt es nun auch mit dem MPlayer unter SuSE 8.1.

Supernature
03.10.02, 00:59
Ich sag schon mal ein ganz fettes Danke - werde leider vor dem Wochenende nicht mehr dazu kommen, aber wenn Du sagst so geht es, dann glaube ich das :bier

knallzapzerap
05.10.02, 14:14
ich habe leider eine Fehlermeldung erhalten.

Error: PNG support required for GUI compilation, please install libpng or libpng-dev packages.

ich habe libpng-dev nachinstalliert, libpng war installiert.
Obwohl ich nachinstalliert habe erhalte ich die Fehlermeldung weiterhin :(

--RAVEN--
05.10.02, 15:20
Was noch benötigt wird wäre: libjpeg

Lösche mal dein temporäres Kompilierverzeichnis und entpacke MPlayer neu da hinein um es nochmal sauber von vorne anzufangen. Nicht vergessen als root einzulogen! ;)

knallzapzerap
05.10.02, 15:40
libjpeg war installiert.
neu entpacken habe ich ebenfalls probiert.
Ich poste mal die Fehlermeldung png betreffend aus der log-Datei

============ Checking for PNG support ============

#include <png.h>
#include <string.h>
int main(void) {
printf("png.h : %s\n", PNG_LIBPNG_VER_STRING);
printf("libpng: %s\n", png_libpng_ver);
return (strcmp(PNG_LIBPNG_VER_STRING, png_libpng_ver));
}

gcc /tmp/mplayer-conf-19141-12071.c -o /tmp/mplayer-conf-29262-12071.o -lpng -lz -lm
In file included from /tmp/mplayer-conf-19141-12071.c:1:
/usr/include/png.h:324:18: zlib.h: Datei oder Verzeichnis nicht gefunden
In file included from /usr/include/png.h:327,
from /tmp/mplayer-conf-19141-12071.c:1:
/usr/include/pngconf.h:1103: parse error before '*' token
/usr/include/pngconf.h:1104: parse error before '*' token
/usr/include/pngconf.h:1105: parse error before '*' token
In file included from /tmp/mplayer-conf-19141-12071.c:1:
/usr/include/png.h:1040: parse error before "z_stream"
/usr/include/png.h:1278: parse error before '}' token

ldd /tmp/mplayer-conf-29262-12071.o
ldd: /tmp/mplayer-conf-29262-12071.o: Datei oder Verzeichnis nicht gefunden

Result is: no

/usr/include/png.h ist als Link auf libpng12/png.h vorhanden
genauso wie die pngconf.h auf /libpng12/pngconf.h verweisst

--RAVEN--
06.10.02, 13:55
Sorry, so spontan fällt mir dazu leider keine Patent-Lösung ein.
Was du aber noch ausprobieren könntest wäre die libpng und libpng-dev nochmal drüber zu installieren. Irgendetwas scheint mit den beiden Dateien nicht zu stimmen, vielleicht ist bei der vorigen Installation was schief gelaufen. Er hat wohl offensichtlich Probleme damit die Header-Dateien zu parsen.

knallzapzerap
06.10.02, 15:10
Habe nach alter Windowsmanier das komplette System neu installiert, leider habe ich den gleichen Fehler weiterhin :(

--RAVEN--
06.10.02, 21:27
Das wäre wohl nicht nötig gewesen, die Pakete nochmal zu installieren hätte genügt.
In einem anderen Forum (http://www.linuxforen.de) hat jemand auf meinen Beitrag gepostet, das es bei ihm genügt hat, die Win32-Codecs in /usr/lib/win32 zu kopieren. Vielleicht reicht das bei dir auch? Ist dann zwar nicht die aktuellste Version, die geben sich aber sowieso nicht soviel. Hauptsache es funktioniert.

Supernature
10.02.03, 21:34
Yeeeeeeeehaaaaaaa!!!!

Sorry, das musste raus - ich hab es tatsächich hinbekommen.
Als kleine Ergänzung: Das Problem "PNG support required for GUI compilation, please install libpng or libpng-dev packages" hatte ich auch, und nachdem ich nicht rausfinden konnte, welche Dev-Pakete mir fehlen, hab ich einfach mit Yast die ganze Rubrik "Entwicklung (erweitert)" installiert. Nun hab ich wohl viel auf der Platte, das ich niemals brauche, aber die ist erstens groß genug und zweitens war die Fehlermeldung dann weg.
Nun gibt der Mplayer auch DivX-Avi's, asf- und wmv-Dateien einwandfrei wieder, und ich hab unter Linux, was ich unter Windows nie geschafft habe: Einen tollen Player mit prima Funktionien für alle Formate.

Supernature
20.05.03, 11:16
Inzwischen hat übrigens auch SuSE gemerkt, dass der mitgelieferte MPlayer so nichts taugt. In der Supportdatenbank erklären sie sogar, warum das so ist und wie man das abstellt :)
http://sdb.suse.de/sdb/de/html/mplayer.html
Nachvollzogen habe ich die Anleitung nicht, diese hier von Raven finde ich ohnehin besser.

--RAVEN--
20.05.03, 17:19
Selbstkompiliert wie zuhause bei Muttern ist es halt doch am Besten :) :lol

:hallo

Hans- Peter
28.05.03, 18:33
Ich habe die Codecs nach /usr/lib/win32 kopiert und die im Verzeichnis bereits vorhandene md5sum* gelöscht, weil ich mir nicht erklären konnte, wozu die gut sein soll, seit dem spielt der mplayer alles ab. :D

Bio-logisch
24.06.03, 17:02
Oder noch einfacher:
Hier gibt es fertige rpms _mit_ allen bekannten Codecs compiliert:

http://packman.links2linux.de/

MfG, Bio-logisch

MaFa
21.08.03, 13:43
Hallo Liste,

erst mal danke für die Anleitung zum Mplayer :)

Und da hab ich aber noch ein Problem ....
Mein SVCD rip wird mir zusammengestaucht angezeigt
ich kann keinen Einfluss über Aspect/Ratio auf das Bild nehmen,
nur das Fenster vergrössert oder verleinert sich.
Das eigentliche Bild wird nicht beeinflusst.

Hiiilfääää :heul

Kann mir dazu bitte jemand von euch helfen ??

Vielen Dank schon im vorraus
und beste Grüße aus N-I bei FFM ;)

--RAVEN--
21.08.03, 14:06
Du kannst die Aspect Ratio die mplayer verwenden soll mit dem Parameter -aspect angeben, also beispielsweise:

gmplayer -aspect 16:9 IrgendeinFilm.avi

MaFa
21.08.03, 14:47
Hallo Raven,

also ich habe das mal versucht und da bekomme ich eine Fehlermeldung,

"file format is not recognized/supported" :rolleyes

nun habe ich über die GUI play SVCD gewählt und da spielt er mir die CD,
aber wie gehabt (da erkennt er aber mein mpeg stream :confused )

Der video decoder [mpegpes] in der console wird mit 480x576 inizialiesiert
bricht aber ab ....

dann wird zum schluss codec [mpeg12] gestartet und der macht mir dieses Bild.

kurze System info:
Toshiba Tecra 8100 / Suse 8.2
Mplayer 0.91

Beste Grüße

MaFa

Judge_Cobba
05.09.03, 13:56
Hi,
danke schonmal für eure überaus gelungene Anleitung.
Ich hab das alles so gemacht wie es da steht und kann auch über die Console jeden Film ohne Probleme starten,
ich hätte aber gerne dieses Steuerungsmodul (weiss jetzt keine treffendere Bezeichnung dafür).
Kann mir jemand sagen wie ich das bekomme?
Ich kann den Mplayer auch nicht einfach so starten mit: mplayer...da bekomme ich dann folgende Fehlermeldung:
"mplayer: error while loading shared libraries: liblzo.so.1: cannot open shared object file: No such file or directory"

Fänd es sau cool, wenn ihr mir helfen könntet. Und sorry schonmal im Vorraus, falls es dazu schon einen Thread gibt.

Gruss Cobba

--RAVEN--
10.09.03, 21:54
Wenn du nach Anleitung vorgegangen bist, dann müsstest du die grafische Oberfläche bereits installiert haben. Gib einfach mal gmplayer in der Konsole ein.


Ich kann den Mplayer auch nicht einfach so starten mit: mplayer...
Wie meinst du das? Wie startest du ihn anderst?

@MaFa:
Hast du auch mal eine andere SVCD ausprobiert?

MaFa
15.09.03, 15:31
Hallo Raven und Liste,

jeep hab mehrere SVCD's getestet und war reichlich frustriert.
Das scheint aber leider auf dem Toshi nicht zu gehn da er nur 8 MB GFX ram hat ...
Und ich hab mir nun einen anderes Laptop gegönnt (Dell Inspiron 8200)
Den Toshi werd ich jetzt aber verticken ... Natürlich mit Linux drauf :) und
nem zusätzlichem Windoof :uzi

Da hab ich aber leider noch nicht die Zeit gehabt um mich an den Mplayer zu machen.
Ich komme da aber bestimmt drauf zurück, im Moment läuft da noch Xine als player der aber
im laufe des Filmes auch "abzusaufen" :( scheint ....

Na ja Die instalation von SuSe 8.2 lief eigentlich recht gut und im Moment bin ich an den I8K
Buttons drann.

Beste Grüße
MaFa

Matze
16.10.03, 21:59
Spitzen Anleitung erstmal muß ich sagen.

Ich habe das ganze so auf meinem Laptop ausgeführt und alles funzt Prima.
Allerdings habe ich das Ganze nochmal auf meinem anderen Rechner Probiert (gleiches BS suse 8.2)
Nur hier bekomme ich die Fehlermeldung:


Checking for GUI ... yes

Error: X11 support required for GUI compilation

Check "configure.log" if you do not understand why it failed.

Nun das ist mir ein bischen zu hoch weil ja mein x prima und fehlerfrei funktioniert.

Hat vieleicht irgend jemand ne idee warum das nicht geht?

--RAVEN--
17.10.03, 10:54
Hast du am dem Rechner auch die XFree86-libs installiert?

Matze
17.10.03, 11:31
Alles Klar Danke.
Daran lags

Pinky und Brain
15.11.03, 14:09
Hallo, habt ihr schon erfahrungen gemachtwie das funktioniert mit dem mplayer und suse 9.0?

Andreas

CyberTroll
15.11.03, 15:12
Hi @ll,

also ich war auch zu faul alles neu zu compilieren, also hab ich es wie Hans- Peter gemacht. Funktioniert allerbestens!

Greetz Jürgen ;-)

--RAVEN--
19.11.03, 21:14
Original geschrieben von Pinky und Brain
Hallo, habt ihr schon erfahrungen gemachtwie das funktioniert mit dem mplayer und suse 9.0?
Funzt genauso wie in der Anleitung beschrieben. Kompilierte ohne Probleme durch.

schmali
06.04.04, 17:47
hallo raven,
ich glaub du kannst mir sicherlich auch weiterhelfen. hab den neueesten mplayer gesaugt und soweit
wie es meine linux-kenntnisse getragen haben verarbeite: ./configure
make install usw. . Nun kann ich den mplayer aus dem terminal heraus starten mit mplayer /dev/dvd.
Nun habe ich so aber keine Bedienoberfläche. Wie bekomm ich die? Wie kann ich mplayer in das startmenu
bekommen. hilfe ein linux-newbie

Supernature
06.04.04, 20:00
Nimmst Du auch ne Antwort von mir? :D
Du musst die Option "-gui" verwenden, damit die Oberfläche mitstartet.
mplayer -gui /dev/dvd

--RAVEN--
06.04.04, 20:12
Oder einfach
gmplayer /dev/dvd
aufrufen :)

BastiBN
17.07.04, 11:56
Hallo,

habe heute den aktuellen mplayer installiert wie es in der Anleitung von -RAVEN- stand. Nach einigen Fehlermeldungen bei "./configure --enable-gui" (es fehlten Dateien) konnte ich make und make install ausführen.

Das hat alles wunderbar geklappt. Aber leider funktioniert der MPlayer nicht. Es blitzt sehr kurz ein Fenster auf und dann nichts.

Wenn ich den Befehl mplayer in der Bash ausführe bekomme ich dann auch Fehlermeldungen.

Die Fehlermeldungen sind wie folgt:

Reading config file /usr/local/etc/mplayer/mplayer.conf: Datei oder Verzeichnis
nicht gefunden
Reading config file /home/Schmitzse/.mplayer/config
Reading /home/Schmitzse/.mplayer/codecs.conf: Can't open '/home/Schmitzse/.mplay
er/codecs.conf': Datei oder Verzeichnis nicht gefunden
Reading /usr/local/etc/mplayer/codecs.conf: Can't open '/usr/local/etc/mplayer/c
odecs.conf': Datei oder Verzeichnis nicht gefunden
Using built-in default codecs.conf.
Usage: mplayer [options] [url|path/]filename


Wer kann mir da weiterhelfen???

Gruß
Basti

Supernature
17.07.04, 12:44
Irgendwas ist da wohl schief gelaufen bei der Installation. Du könntest nun mal suchen, wo die "mplayer.conf" tatsächlich liegt und dann einen symbolischen Link nach /usr/local/etc/mplayer/ erstellen.
Ich zweifle aber, ob das funktioniert - zumal ja nicht mal die Daten im Home-Directory gefunden werden.

Bio-logisch
17.07.04, 12:47
Ist doch alles in Ordnung:
Er sucht nach den verschiedenen Config - Dateien, findet aber keine. Daher verwendet er die default einstellung.
Am Ende gibt er dir aus, wie du in starten kannst:

mplayer filename.typ

Es ist also alles in allerbester Ordnung.
Falls du eine gui erwartet hast, die wird mit dem Befehl
gmplayer aufgerufen (falls sie kompiliert wurde)

Wenn es beim compilieren Probleme gab, wird warscheinlich irgendein Modul fehlen.
Das kannst im config.log nachlesen.

MfG, Bio-logisch

BastiBN
17.07.04, 13:17
Habe den Fehler gefunden.

Lt. der Anleitung war "Skin/Default" gross geschrieben... Damit kam er nicht klar...

Habe jetzt den Ordner default klein geschrieben und siehe da es funzt...

Besten Dank.

Gast123
18.07.04, 17:46
Hi, ich bin am durchdrehen...
sobald ich make eintippe klappt alles wunderbar, doch er schließt dann mit der meldung:

ffv1.c: In function `encode_rgb_frame':
ffv1.c:465: internal compiler error: in find_function_data, at function.c:319
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://www.suse.de/feedback> for instructions.
make[1]: *** [ffv1.o] Error 1
make[1]: Leaving directory `/home/PC/Documents/MPlayer-1.0pre5/libavcodec'
make: *** [libavcodec/libavcodec.a] Fehler 2

kann mir jmd helfen?

Bio-logisch
18.07.04, 18:12
Nun, offensichtlich ein Fehler im Compiler selber.
Da kann man eigentlich nur eines machen: Mplayer ohne diesen libavcodec installieren. Das müsste sich beim ./configure abschalten lassen:
Gib mal ./configure --help ein, das gibt alle möglichen Optionen für das ./configure aus.

Alternativ: Auf http://www.packman.links2linux.de gibt es fertig kompilierte Pakete für Suse.
Sie lassen sich besonders einfach über apt4rpm installieren: http://linux01.gwdg.de/apt4rpm/

MfG, Bio-logisch

tlx
19.07.04, 14:45
Kann auch ein Speicherfehler sein, was ich laut dieser Meldung eher nicht annehmen würde. Weiters kannst du den Quellcode ja noch ansehen und nach dieser Expression suchen ... wär viel Arbeit. Schließe mich daher Bio an: vorkompilierte Pakete, am besten für deinen Prozessor optimierte.

BastiBN
27.07.04, 00:25
Hi

wollte gerade den Mplayer 1.0 unter SuSE Linux 9.1 Personal installieren.

Nur leider kommt bei "../configure --enable-gui" immer noch, nachdem ich sämtliche gtk devel packages die auf rpmseek zu finden sind installiert habe, die fehlermeldung "Checking for GTK version ...
Error: The GUI requires GTK devel packages (which were not found)."

Welche Packete brauche ich im einzelnen?

Wer kann mir da weiterhelfen?

Gruß und besten dank

Bio-logisch
27.07.04, 09:40
Schau mal im config.log nach, an welcher Stelle des configure Scriptes der Fehler augetreten ist.
Dort steht dann, wonach genau gesucht wird.
Damit solltest Du herausfinden können, woran es klemmt.

Unregistriert
25.08.05, 17:50
na ja. ich weiss es nicht, ob es passend zu diesem Thema ist. Aber ich habe gefunden wie man w32codecs auf ubuntu (bzm. debian) installiert.
Hier ist die Beschreibung: http://www.ubuntuusers.de/wiki/multimedia:unterstuetzung?s=wmv

ZuluDC
25.08.05, 22:46
Ich glaube es wäre einer der unten aufgeführten Einträge in der sources.list der zum Ziel führen kann (ich rede jetzt aber nur für debianbasierende Distributionen).

#deb ftp://ftp.nerim.net/debian-marillat/ stable main
#deb ftp://ftp.nerim.net/debian-marillat/ testing main
#deb ftp://ftp.nerim.net/debian-marillat/ unstable main

Der entsprechende Eintrag müsste natürlich noch auskommentiert werden.

Was mir noch an MPlayer aufgefallen ist, ist, dass er mittels des Befehls gmplayer gestartet wird.

Der MPlayer ist an sich ein extremes Hammerteil. Man kann da scheusslich viel über irgendwelche Textdateien konfigurieren z.B für einzelne Filme festlegen, dass die Farben invers dargestellt werden...sieht dann etwa so aus wie einzelne Szenen im letzten Koyanisqatsi-Film :-)

Zu dumm nur, das das Teil nie und nimmer die Stabilität von xine (gxine) erreicht (das merkt man vorallem, wenn man an MPlayer rumspielt während er einen Film abspielt - crasht oft hammerhart). Aber xine ist ja wirklich auch ein sackgeiles Teil und greift auf den gleichen Ordner mit den Plugins zu.

<modus=ot>

Apropos...hat schon jemand mal hier den Videomodus (overlay) unter Linux laufen gehabt. Ich meine das was vlc, windvd oder bsplayer unter WindowsXP können - Filme hinter den Icons apspielen?

</modus=ot>

Bio-logisch
23.10.06, 14:08
Ich schreib das mal hier rein:
Version 1.0 RC1 ist erschienen. Pro-Linux News: MPlayer 1.0 RC1 freigegeben (http://www.pro-linux.de/news/2006/10379.html)